WordPress FAQ: Where did my Preview Link Go?

Where the hell did my “Preview Post” button go? We lost it with the Upgrade to 2.1, and I want it back.

This question comes from Cory Aldrich who echoes the sentiments of many WordPress users. In WordPress 2.1, the iframe that loaded the site in a window below the edit area of the Write screen, was removed. Mostly this was due to performance issue of loading a whole site inside a window. The outcry has been heard, however, and the Preview link has been restored to WordPress 2.2 – in a slightly different form. Changeset 5159 went back into the core on March 31st.

Feel free to email me your WordPress questions so I can help you get an answer.

Aaron Brazell

Aaron Brazell is a Baltimore, MD-based WordPress developer, a co-founder at WP Engine, WordPress core contributor and author. He wrote the book WordPress Bible and has been publishing on the web since 2000. You can follow him on Twitter, on his personal blog and view his photography at The Aperture Filter.

12 thoughts on “WordPress FAQ: Where did my Preview Link Go?

  1. In WordPress 2.1, the iframe that loaded the site in a window below the edit area of the Write screen, was removed.

    The iframe is still there. Just the button was removed (yeah I know, that seems odd). But if you click “Save” and scroll down, you’ll see your preview.

  2. Good call, Handy. Guess I’ll write a patch to remove it. I don’t see much point in it being there with the Preview Link opening a new window. It just slows the load time of the wp-admin

  3. WP 2.1.2 left the iframe but removed the preview link. WP 2.2 (i.e. trunk) removes the iframe in place of a preview link which opens the preview in another window. Sorry about the confusion.

  4. Yeah, you probably want to rewrite the FAQ article above because HandySolo has it correct.

    I have no idea what is causing the problem Cory Aldrich is experiencing — maybe he is assuming that because the link is missing.

  5. Lloyd, thanks, but again…

    The preview button is gone in 2.1. The iframe is there. In trunk, the iframe is gone and the preview button is back as a link.

    Think I said that in comment #6. I can take screenshots if you need proof. ;)

  6. No one reads the comments ;-) Your “FAQ” reads “In WordPress 2.1, the iframe that loaded the site in a window below the edit area of the Write screen, was removed.” which is incorrect.

    Anyway, these FAQ entries are brilliant!

Comments are closed.